What are the system requirements (required operating environment)?

— Windows Vista® Home Basic/Home Premium/Ultimate/Business
— Windows® XP Home Edition/Professional (SP2 or later)
The driver software is not compatible with 64-bit operating systems (Windows® XP Professional x64 Edition and 64-bit editions of Windows Vista®).
— Mac OS X (10.3.9 or later)
When using DJ applications, check the application's required operating environment.

Rate this Question/Answer

How well did this answer your question?

0% 25% 50% 75% 100%

If you have any otherfeedback on our FAQs, please provide it here. This form is intended for feedback only. We are unable to respond to questions submitted here. If you have a question or an inquiry, please contact us by Email.

Can't find your answer here? Try our Knowledgebase.

Support Quick Links
Parts

Find Replacement Parts

For General Service & Support

call 1-800-421-1404
or contact us by e-mail

Hours of Operation

Monday - Friday
10:30 a.m. - 7:00 p.m. EST